cdg.net

CDG Forums
Your Ad Here
It is currently Sat Nov 25, 2017 8:21 am

All times are UTC [ DST ]




Post new topic Reply to topic  [ 55 posts ]  Go to page Previous  1, 2, 3, 4
Author Message
 Post subject:
PostPosted: Wed Jun 21, 2006 3:42 pm 
Offline
Old Timer
User avatar

Joined: Mon Sep 05, 2005 12:24 am
Posts: 512
Location: Shanghai, China
great zoidburg, but i tried it and i still have the same problem.
here is the qc for an m4:


$attachment "2" "ejection" 0.00 0.00 0.00 rotate -90.00 0.00 0.00
$surfaceprop "default"
$illumposition -0.611 10.425 -8.760
$sequence idle "idle" ACT_VM_IDLE_SILENCED 1 snap rotate -90 fps 30.00
$sequence shoot1 "shoot1" ACT_VM_PRIMARYATTACK_SILENCED 1 snap rotate -90 fps 30.00 {
{ event 5001 0 "1" }
{ event AE_CLIENT_EFFECT_ATTACH 0 "EjectBrass_556 2 80" }
}

$sequence shoot2 "shoot2" ACT_VM_PRIMARYATTACK_SILENCED 1 snap rotate -90 fps 30.00 {
{ event 5001 0 "1" }
{ event AE_CLIENT_EFFECT_ATTACH 0 "EjectBrass_556 2 80" }
}

$sequence shoot3 "shoot3" ACT_VM_PRIMARYATTACK_SILENCED 1 snap rotate -90 fps 30.00 {
{ event 5001 0 "1" }
{ event AE_CLIENT_EFFECT_ATTACH 0 "EjectBrass_556 2 80" }
}

$sequence reload "reload" ACT_VM_RELOAD_SILENCED 1 snap rotate -90 fps 30.00 {
{ event 5004 11 "Weapon_M4A1.Clipout" }
{ event 5004 40 "Weapon_M4A1.Clipin" }
}

$sequence draw "draw" ACT_VM_DRAW_SILENCED 1 snap rotate -90 fps 30.00
$sequence add_silencer "add_silencer" ACT_VM_ATTACH_SILENCER 1 snap rotate -90 fps 30.00 {
{ event 5004 15 "Weapon_M4A1.Silencer_On" }
}

$sequence idle_unsil "idle_unsil" ACT_VM_IDLE 1 snap rotate -90 fps 16.00
$sequence shoot1_unsil "shoot1_unsil" ACT_VM_PRIMARYATTACK 1 snap rotate -90 fps 30.00 {
{ event 5001 0 "1" }
{ event AE_CLIENT_EFFECT_ATTACH 0 "EjectBrass_556 2 80" }
}

$sequence shoot2_unsil "shoot2_unsil" ACT_VM_PRIMARYATTACK 1 snap rotate -90 fps 30.00 {
{ event 5001 0 "1" }
{ event AE_CLIENT_EFFECT_ATTACH 0 "EjectBrass_556 2 80" }
}

$sequence shoot3_unsil "shoot3_unsil" ACT_VM_PRIMARYATTACK 1 snap rotate -90 fps 30.00 {
{ event 5001 0 "1" }
{ event AE_CLIENT_EFFECT_ATTACH 0 "EjectBrass_556 2 80" }
}

$sequence reload_unsil "reload_unsil" ACT_VM_RELOAD 1 snap rotate -90 fps 30.00 {
{ event 5004 11 "Weapon_M4A1.Clipout" }
{ event 5004 34 "Weapon_M4A1.Clipin" }
}

$sequence draw_unsil "draw_unsil" ACT_VM_DRAW 1 snap rotate -90 fps 30.00
$sequence detach_silencer "detach_silencer" ACT_VM_DETACH_SILENCER 1 snap rotate -90 fps 32.00 {
{ event 5004 20 "Weapon_M4A1.Silencer_Off" }
$origin 0 .5 0
}


BTW, you have all told me something different about this snap rotate thing!

_________________
Image


Top
 Profile  
 
 Post subject:
PostPosted: Thu Jun 22, 2006 1:45 am 
Offline
Wise Old Man
User avatar

Joined: Mon Mar 07, 2005 11:42 pm
Posts: 1566
Location: Phoenix, AZ
computerduderec wrote:
great zoidburg, but i tried it and i still have the same problem.
here is the qc for an m4:


$attachment "2" "ejection" 0.00 0.00 0.00 rotate -90.00 0.00 0.00
$surfaceprop "default"
$illumposition -0.611 10.425 -8.760
$sequence idle "idle" ACT_VM_IDLE_SILENCED 1 snap rotate -90 fps 30.00
$sequence shoot1 "shoot1" ACT_VM_PRIMARYATTACK_SILENCED 1 snap rotate -90 fps 30.00 {
{ event 5001 0 "1" }
{ event AE_CLIENT_EFFECT_ATTACH 0 "EjectBrass_556 2 80" }
}

$sequence shoot2 "shoot2" ACT_VM_PRIMARYATTACK_SILENCED 1 snap rotate -90 fps 30.00 {
{ event 5001 0 "1" }
{ event AE_CLIENT_EFFECT_ATTACH 0 "EjectBrass_556 2 80" }
}

$sequence shoot3 "shoot3" ACT_VM_PRIMARYATTACK_SILENCED 1 snap rotate -90 fps 30.00 {
{ event 5001 0 "1" }
{ event AE_CLIENT_EFFECT_ATTACH 0 "EjectBrass_556 2 80" }
}

$sequence reload "reload" ACT_VM_RELOAD_SILENCED 1 snap rotate -90 fps 30.00 {
{ event 5004 11 "Weapon_M4A1.Clipout" }
{ event 5004 40 "Weapon_M4A1.Clipin" }
}

$sequence draw "draw" ACT_VM_DRAW_SILENCED 1 snap rotate -90 fps 30.00
$sequence add_silencer "add_silencer" ACT_VM_ATTACH_SILENCER 1 snap rotate -90 fps 30.00 {
{ event 5004 15 "Weapon_M4A1.Silencer_On" }
}

$sequence idle_unsil "idle_unsil" ACT_VM_IDLE 1 snap rotate -90 fps 16.00
$sequence shoot1_unsil "shoot1_unsil" ACT_VM_PRIMARYATTACK 1 snap rotate -90 fps 30.00 {
{ event 5001 0 "1" }
{ event AE_CLIENT_EFFECT_ATTACH 0 "EjectBrass_556 2 80" }
}

$sequence shoot2_unsil "shoot2_unsil" ACT_VM_PRIMARYATTACK 1 snap rotate -90 fps 30.00 {
{ event 5001 0 "1" }
{ event AE_CLIENT_EFFECT_ATTACH 0 "EjectBrass_556 2 80" }
}

$sequence shoot3_unsil "shoot3_unsil" ACT_VM_PRIMARYATTACK 1 snap rotate -90 fps 30.00 {
{ event 5001 0 "1" }
{ event AE_CLIENT_EFFECT_ATTACH 0 "EjectBrass_556 2 80" }
}

$sequence reload_unsil "reload_unsil" ACT_VM_RELOAD 1 snap rotate -90 fps 30.00 {
{ event 5004 11 "Weapon_M4A1.Clipout" }
{ event 5004 34 "Weapon_M4A1.Clipin" }
}

$sequence draw_unsil "draw_unsil" ACT_VM_DRAW 1 snap rotate -90 fps 30.00
$sequence detach_silencer "detach_silencer" ACT_VM_DETACH_SILENCER 1 snap rotate -90 fps 32.00 {
{ event 5004 20 "Weapon_M4A1.Silencer_Off" }
$origin 0 .5 0
}


BTW, you have all told me something different about this snap rotate thing!


I see were your problem is you have the $origin comand in one of the sequences. move comand in between the $illumposition comand and the first sequence comand here is an example


attachment "2" "ejection" 0.00 0.00 0.00 rotate -90.00 0.00 0.00
$surfaceprop "default"
$illumposition -0.611 10.425 -8.760
$origin 0 0 0
$sequence idle "idle" ACT_VM_IDLE_SILENCED 1 snap rotate -90 fps 30.00
$sequence shoot1 "shoot1" ACT_VM_PRIMARYATTACK_SILENCED 1 snap rotate -90 fps 30.00 {
{ event 5001 0 "1" }
{ event AE_CLIENT_EFFECT_ATTACH 0 "EjectBrass_556 2 80" }
}

_________________
Image


Top
 Profile  
 
 Post subject:
PostPosted: Thu Jun 22, 2006 2:25 pm 
Offline
Old Timer
User avatar

Joined: Mon Sep 05, 2005 12:24 am
Posts: 512
Location: Shanghai, China
thx it works mostly

one question tho
4. Now the x y z will be replaced with numbers so let me explain x means closer or farter to the screen, y means left to right of the screen, and z means up or down on the screen

for the first direction (ex: closer, left, up) do i use negative numbers
and the second direction (ex: further, right, down) positive numbers?
:?:

_________________
Image


Top
 Profile  
 
 Post subject:
PostPosted: Mon Aug 07, 2006 7:40 pm 
Offline
Adolescent

Joined: Wed Mar 08, 2006 3:52 pm
Posts: 125
Location: Germany
mh okay..i have changed the origins.. i have all done what you say in the tutorial.. but.. it dosnt work.
i have compiled it and now.. its the default glock?!
qc:
Code:
$cd "G:\zeug\origiiin"
$modelname "weapons\v_pist_glock18.mdl"
$model "studio" "glock_ref.smd"
$cdmaterials "models\weapons\v_models\pist_glock18\"
$cdmaterials "models\weapons\v_models\hands\"
$hboxset "default"
$hbox 0 "SphereGizmo03" -6.259  -13.632  -8.776  10.313  0.000  6.194
$hbox 0 "Bone25" -8.737  -1.968  -1.724  0.000  1.071  1.071
$hbox 0 "Bone26" -2.806  -1.378  -0.952  0.000  1.529  1.040
$hbox 0 "Bone27" -1.319  -0.408  -0.942  0.187  0.680  0.577
$hbox 0 "Bone02" -9.056  -1.586  -1.508  0.000  1.592  1.152
$hbox 0 "Bone03" -3.155  -1.454  -1.093  0.000  1.574  0.893
$hbox 0 "frame" -3.578  -2.802  -0.596  3.587  1.728  0.589
$origin 1.5 -2.3 -2.0
// Model uses material "v_hands.vmt"
// Model uses material "clip.vmt"
// Model uses material "handle.vmt"
// Model uses material "details.vmt"
// Model uses material "slide.vmt"
// Model uses material "lam.vmt"
// Model uses material "barrel.vmt"
$attachment "1" "slide" 3.40 0.00 0.00 rotate 0.00 0.00 -0.00
$attachment "2" "slide" 0.00 0.00 0.00 rotate 90.00 -0.00 0.00
$surfaceprop "default"
$illumposition 2.315 -0.608 -8.865
$sequence glock_idle "glock_idle" ACT_VM_IDLE 1 snap rotate -90 30.00
$sequence glock_fireburst1 "glock_fireburst1" ACT_VM_SECONDARYATTACK 1 snap rotate -90 40.00 {
  { event 5001 0 "1" }
  { event 5001 2 "1" }
  { event 5001 3 "1" }
  { event AE_CLIENT_EFFECT_ATTACH 0 "EjectBrass_9mm 2 90" }
  { event AE_CLIENT_EFFECT_ATTACH 2 "EjectBrass_9mm 2 90" }
  { event AE_CLIENT_EFFECT_ATTACH 3 "EjectBrass_9mm 2 90" }
}

$sequence glock_fireburst2 "glock_fireburst2" ACT_VM_SECONDARYATTACK 1 snap rotate -90 40.00 {
  { event 5001 0 "1" }
  { event 5001 2 "1" }
  { event 5001 3 "1" }
  { event AE_CLIENT_EFFECT_ATTACH 0 "EjectBrass_9mm 2 90" }
  { event AE_CLIENT_EFFECT_ATTACH 2 "EjectBrass_9mm 2 90" }
  { event AE_CLIENT_EFFECT_ATTACH 3 "EjectBrass_9mm 2 90" }
}

$sequence glock_firesingle "glock_firesingle" ACT_VM_PRIMARYATTACK 1 snap rotate -90 40.00 {
  { event 5001 0 "1" }
  { event AE_CLIENT_EFFECT_ATTACH 0 "EjectBrass_9mm 2 90" }
}

$sequence glock_firelast "glock_firelast" ACT_VM_DRYFIRE 1 snap rotate -90 35.00 {
  { event 5001 0 "21" }
}

$sequence glock_draw "glock_draw" ACT_VM_DRAW 1 snap rotate -90 34.00 {
  { event 5004 7 "weapons/glock/sliderack.wav" }
}

$sequence glock_reload "glock_reload" ACT_VM_RELOAD 1 snap rotate -90 43.00 {
  { event 5004 2 "weapons/glock/vun_spindraw.wav" }
  { event 5004 23 "weapons/glock/vun_clipout.wav" }
  { event 5004 59 "weapons/glock/vun_clipin.wav" }
  { event 5004 79 "weapons/glock/vun_sliderelease.wav" }
}


whats wrong? :(

//edit:
ok i have recompiled it and now this message come on the dos window:
Image

_________________
Image


Top
 Profile  
 
 Post subject:
PostPosted: Sun Aug 13, 2006 1:01 pm 
Offline
His ass is...
His ass is...

Joined: Thu Aug 25, 2005 8:45 pm
Posts: 3464
Location: what
it's missing a file "30.00" which makes no sense..

_________________
Karbine: whatt
Karbine: dud
Karbine: dude
Karbine: i am too fucking drunk to do that right now
Karbine: my dick is hard
Karbine: brb


Top
 Profile  
 
 Post subject: Default origins?
PostPosted: Sun Aug 13, 2006 3:37 pm 
Offline
Old Timer
User avatar

Joined: Wed Feb 22, 2006 9:47 pm
Posts: 492
Location: The highlands.
What are the default origins? the numbers in order x y z.

This has helped ty

_________________
Image


Top
 Profile  
 
 Post subject: Problem :/
PostPosted: Sun Aug 13, 2006 5:09 pm 
Offline
Old Timer
User avatar

Joined: Wed Feb 22, 2006 9:47 pm
Posts: 492
Location: The highlands.
Ok im getting a message whenever i start a new game or go onto a server:

Edit: Fixed

Whats tht sposed to mean?

Heres my qc:

$cd "C:\Program Files\Valve\steam\SteamApps\----\counter-strike source"
$origin 4 2 3
$modelname "weapons\v_rif_m4a1.mdl"
$model "studio" "m4a1_reference.smd"
$model "hands" "hands_reference.smd"
$cdmaterials "models\weapons\V_models\rif_m4a1\"
$cdmaterials "models\weapons\v_models\hands\"
$hboxset "default"
$hbox 0 "v_weapon.m4_Parent" -0.581 -0.922 -6.757 1.360 5.699 15.093
$hbox 0 "v_weapon.m4_Clip" -0.880 -3.738 -0.872 0.451 0.450 1.617
$hbox 0 "v_weapon.Hands_parent" -4.654 -1.415 0.000 6.834 1.302 6.902
$hbox 0 "v_weapon.Left_Arm" -0.319 -1.833 -1.434 8.563 1.491 1.708
$hbox 0 "v_weapon.Left_Hand" -0.998 -1.856 -1.460 3.655 1.901 1.020
$hbox 0 "v_weapon.Left_Thumb01" -0.038 -0.957 -1.026 2.195 0.816 0.689
$hbox 0 "v_weapon.Left_Thumb_02" -0.557 -0.812 -0.925 1.705 0.536 0.541
$hbox 0 "v_weapon.Left_Pinky01" -0.563 -0.567 -0.680 1.253 1.426 0.518
$hbox 0 "v_weapon.Left_Ring01" -0.051 -0.398 -0.616 1.498 0.636 0.413
$hbox 0 "v_weapon.L_wrist_helper" -0.805 -6.918 -1.161 1.745 0.000 2.128
$hbox 0 "v_weapon.Right_Arm" -0.402 -1.437 -1.576 8.544 1.387 1.609
$hbox 0 "v_weapon.Right_Hand" -0.402 -1.775 -1.494 3.638 1.715 0.913
$hbox 0 "v_weapon.Right_Thumb01" -0.867 -1.013 -1.300 2.356 1.051 0.852
$hbox 0 "v_weapon.Right_Thumb02" -1.285 -0.580 -0.979 1.751 0.994 0.680
$hbox 0 "v_weapon.Right_Middle01" -0.061 -0.689 -0.475 1.376 0.379 0.545
$hbox 0 "v_weapon.Right_Ring01" -0.256 -0.648 -0.542 1.312 0.423 0.473
$hbox 0 "v_weapon.Right_Pinky01" -0.456 -1.085 -0.539 1.124 0.488 0.691
$hbox 0 "v_weapon.R_wrist_helper" -1.175 -7.124 -1.587 1.829 0.933 2.029
// Model uses material "rif_m4a1.vmt"
// Model uses material "v_hands.vmt"
$attachment "1" "v_weapon.m4_Parent" 0.20 3.50 20.00 rotate 0.00 0.00 0.00
$attachment "2" "v_weapon.m4_Parent" 0.00 3.60 3.00 rotate -30.00 165.00 -0.00
$surfaceprop "default"
$illumposition 9.538 3.995 -6.393
$sequence idle "idle" ACT_VM_IDLE_SILENCED 1 snap rotate -90 fps 16.00
$sequence shoot1 "shoot1" ACT_VM_PRIMARYATTACK_SILENCED 1 snap rotate -90 fps 20.00 {
{ event 5001 0 "1" }
{ event AE_CLIENT_EFFECT_ATTACH 0 "EjectBrass_556 2 150" }
}

$sequence shoot2 "shoot2" ACT_VM_PRIMARYATTACK_SILENCED 1 snap rotate -90 fps 20.00 {
{ event 5001 0 "1" }
{ event AE_CLIENT_EFFECT_ATTACH 0 "EjectBrass_556 2 150" }
}

$sequence shoot3 "shoot3" ACT_VM_PRIMARYATTACK_SILENCED 1 snap rotate -90 fps 20.00 {
{ event 5001 0 "1" }
{ event AE_CLIENT_EFFECT_ATTACH 0 "EjectBrass_556 2 150" }
}

$sequence reload "reload" ACT_VM_RELOAD_SILENCED 1 snap rotate -90 fps 37.00 {
{ event 5004 25 "Weapon_M4A1.Clipout" }
{ event 5004 53 "Weapon_M4A1.Clipin" }
{ event 5004 88 "Weapon_M4A1.Boltpull" }
}

$sequence draw "draw" ACT_VM_DRAW_SILENCED 1 snap rotate -90 fps 40.00 {
{ event 5004 1 "Weapon_M4A1.Deploy" }
{ event 5004 17 "Weapon_M4A1.Boltpull" }
}

$sequence add_silencer "add_silencer" ACT_VM_ATTACH_SILENCER 1 snap rotate -90 fps 30.00 {
{ event 5004 28 "Weapon_M4A1.Silencer_On" }
}

$sequence idle_unsil "idle_unsil" ACT_VM_IDLE 1 snap rotate -90 fps 16.00
$sequence shoot1_unsil "shoot1_unsil" ACT_VM_PRIMARYATTACK 1 snap rotate -90 fps 20.00 {
{ event 5001 0 "1" }
{ event AE_CLIENT_EFFECT_ATTACH 0 "EjectBrass_556 2 150" }
}

$sequence shoot2_unsil "shoot2_unsil" ACT_VM_PRIMARYATTACK 1 snap rotate -90 fps 20.00 {
{ event 5001 0 "1" }
{ event AE_CLIENT_EFFECT_ATTACH 0 "EjectBrass_556 2 150" }
}

$sequence shoot3_unsil "shoot3_unsil" ACT_VM_PRIMARYATTACK 1 snap rotate -90 fps 20.00 {
{ event 5001 0 "1" }
{ event AE_CLIENT_EFFECT_ATTACH 0 "EjectBrass_556 2 150" }
}

$sequence reload_unsil "reload_unsil" ACT_VM_RELOAD 1 snap rotate -90 fps 37.00 {
{ event 5004 25 "Weapon_M4A1.Clipout" }
{ event 5004 53 "Weapon_M4A1.Clipin" }
{ event 5004 88 "Weapon_M4A1.Boltpull" }
}

$sequence draw_unsil "draw_unsil" ACT_VM_DRAW 1 snap rotate -90 fps 40.00 {
{ event 5004 1 "Weapon_M4A1.Deploy" }
{ event 5004 17 "Weapon_M4A1.Boltpull" }
}

$sequence detach_silencer "detach_silencer" ACT_VM_DETACH_SILENCER 1 snap rotate -90 fps 30.00 {
{ event 5004 21 "Weapon_M4A1.Silencer_Off" }
}


Edit: Fixed

_________________
Image


Top
 Profile  
 
 Post subject:
PostPosted: Thu Aug 24, 2006 9:54 pm 
Offline
Old Timer
User avatar

Joined: Sun Jan 23, 2005 6:28 am
Posts: 558
Location: Jersey Bitch!
alright I am rather flustered by these two programs, I have 0.5, I just downloaded both SDK programs from Steam, I've been trying to fallow the directions that were given on this thread.

I've gotten as far as being able to decompile a model, then the program crashes completely and the .qc file is blank and is titled mdldecompiler.qc. I was getting the error message Extra App ID set to 211, but no SteamAppID, I tried to fix it and it worked only after I killed the original gameinfo off and unselected the third option on the decompiler.

I can hardly figure out how to get the SDK program to properly.

I used to be able to do this stuff back in the days of HL1 but now to me its changed, I don't know what the hell I'm doing wrong but its agitating.

_________________
Position target in the center, pull the switch.


Top
 Profile  
 
 Post subject:
PostPosted: Wed Nov 01, 2006 1:25 am 
Offline
Posts way too much...
User avatar

Joined: Sun Mar 14, 2004 3:28 pm
Posts: 16822
Location: A touch of class.
Where does it go once you compile :|

_________________
Everyone is in love and flowers pick themselves.


Top
 Profile  
 
 Post subject:
PostPosted: Sat Nov 25, 2006 4:23 am 
Offline
Old Timer
User avatar

Joined: Mon Sep 05, 2005 12:24 am
Posts: 512
Location: Shanghai, China
after u compile it should be in your models folder already.
If u do it properly, when u go in game it should be there already.


EDIT: btw, i noticed this thread is slow as hell :D


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 55 posts ]  Go to page Previous  1, 2, 3, 4

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Your Ad Here
Powered by phpBB® Forum Software © phpBB Group